Shoutbox (Disabled)

Support The game will not start, logs say "OpenGL 2.1 support is required!"

Discussion in 'Support' started by Amani Jackson, Nov 24, 2016.

  1. Amani Jackson

    Amani Jackson New Member

    Messages:
    6
    Likes Received:
    1
    When I try to start Amorous, whether through the launcher or from the application itself, a window shows up that says
    Microsoft.Xna.Framework.Graphics.NoSuitableGraphicsDeviceException: OpenGL 2.1 support is required!

    In the logs, it says the same thing but with "[0000.19] Error:" and some lines below it starting with "Microsoft.Xna.Framework". I was able to play v3 with no issues, some lag when starting sex scenes but it went away after a minute, and the files are verified as there.
     
  2. Lennian

    Lennian Dark Lord of Team Amorous Team Amorous

    Messages:
    2,207
    Likes Received:
    939
    This ain't v0.3 anymore and as it states, you would need OpenGL 2.1 to play the game. What are your specs?
     
  3. Amani Jackson

    Amani Jackson New Member

    Messages:
    6
    Likes Received:
    1
    Windows 10 x64
    Processor: Intel Celeron 2.20 GHz
    Ram: 4gb (3.87 usable)
    Chip: Mobile Intel(R) 4 Series Express Chipset Family
     
  4. Lennian

    Lennian Dark Lord of Team Amorous Team Amorous

    Messages:
    2,207
    Likes Received:
    939
  5. Amani Jackson

    Amani Jackson New Member

    Messages:
    6
    Likes Received:
    1
    I tried installing it but it says I do not meet minimum requirements, it's probably because I have an old laptop with Windows 10, thanks anyway.
     
  6. Lennian

    Lennian Dark Lord of Team Amorous Team Amorous

    Messages:
    2,207
    Likes Received:
    939
    Apparantly it takes a few steps: Download the one from this video and follow the video too.

     
  7. Amani Jackson

    Amani Jackson New Member

    Messages:
    6
    Likes Received:
    1
    It starts up now, it's still kinda laggy but I can deal. Thanks A lot, and Happy Thanksgiving!
     
  8. Lennian

    Lennian Dark Lord of Team Amorous Team Amorous

    Messages:
    2,207
    Likes Received:
    939
    No problem, thanks for reporting back, that's good hope for future people since I have seen this chipset a lot already :) Future version will also get optimized.
     
  9. Misign0

    Misign0 New Member

    Messages:
    3
    Likes Received:
    1
    My configuration is
    Processor Intel(R) Core(Tm)2 Quad CPU Q8400
    Ram 2.00G
    System Time 32-bits Operating System, x64 based processor
    Video Card Intel G33/G31 Express Chipset Family
    And i[m having the same issue
     
  10. CrimsonVial

    CrimsonVial New Member

    Messages:
    1
    Likes Received:
    0
    I'm getting the same OpenGL problem, but I'm using Windows 7 Ultimate.
     

Share This Page