Shoutbox (Disabled)

New Some Linux Issues and Fixes

Discussion in 'Open' started by Penguin_Bugger, Jul 27, 2021.

  1. Penguin_Bugger

    Penguin_Bugger New Member

    Messages:
    1
    Likes Received:
    0
    First, my setup

    Version: 1.0.4 from itch\.io
    OS: Manjaro Linux
    GPU: AMD RX 480 using Mesa 21.1.5 driver
    OpenGL Driver: 4.6
    (if you want more info, feel free to ask)

    Getting the game

    As mentioned before, I got the game from itch\.io and extracted it to its own folder in a Games folder under my home directory. It didn't want to open at first. Not through the shell script or either of the executables included. I tried running the Windows executable that is in the archive with Wine with no luck. I tried running the Windows archive with Wine still with no luck.

    Issues and Solutions

    Short of it is, I was able to get the game working and fix a couple of crashes and issues from my side. It seems like there is an issue with capitalization throughout the sub-directories as it is referenced in the code. Fortunately, the logs are pretty clear about this, so normally you can find the 'missing' asset and rename it to get it working.

    Shell Script not Working: The shell script completes before the executable has a chance to launch. Since the executable is owned by the script's process, you'll have to disown it. This is an easy fix. On lines 34 and 36 of "<Amorous Directory>/Amorous[.]Game[.]Unix" (had to alter the periods to avoid tripping the URL alert), append " &" to the command to run the appropriate executable. This will disown the game process from the script process so the script will end without affecting the game.

    Game not Opening: The problem that I found with the game not launching at all from the executable was that there are some references to "<Amorous Directory>/Content-Release/Assets/GUI/" and some references to "<Amorous Directory>/Content-Release/Assets/Gui/". I found I was able to fix this problem by making a symbolic link to the GUI folder that offered that alternative name:
    $ ln -s '<Amorous Directory>/Content-Release/Assets/GUI/' '<Amorous Directory>/Content-Release/Assets/Gui/'
    Game Crashing on Certain Content: I found this issue first with Coby's sex scene. It consistently crashed when you went to fucking so I checked the logs. It turns out "Coby Sex Spine" suffered another capitalization issue. Renaming the files did the job. For these files, since there aren't too many alternate reference to them, it would be preferable to rename them rather than link them, but directories you will absolutely want to link.



    I am willing to keep this thread updated with any other issues and fixes I find until mods want me to handle it some other way.
     

Share This Page