Shoutbox (Disabled)

Support Get System.DllNotFoundException but have Visual C++ 2010 (x86) installed

Discussion in 'Support' started by ThatOneGuy289, Nov 20, 2016.

  1. ThatOneGuy289

    ThatOneGuy289 New Member

    Messages:
    5
    Likes Received:
    0
    I have installed Visual C++ 2010 (x86) from the FAQ, along with .NET Framw0rk 4.5, but still get this error:
    [0000.09] Error: Unhandled exception: System.DllNotFoundException: Unable to load DLL 'MojoShader.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
    at MojoShader.INTERNAL_glBestProfile(MOJOSHADER_glGetProcAddress lookup, IntPtr lookup_d, MOJOSHADER_malloc m, MOJOSHADER_free f, IntPtr malloc_d)
    at Microsoft.Xna.Framework.Graphics.OpenGLDevice..ctor(PresentationParameters presentationParameters, GraphicsAdapter adapter)
    at Microsoft.Xna.Framework.SDL2_FNAPlatform.CreateGLDevice(PresentationParameters presentationParameters, GraphicsAdapter adapter)
    at Microsoft.Xna.Framework.Graphics.GraphicsDevice..ctor(GraphicsAdapter adapter, GraphicsProfile graphicsProfile, PresentationParameters presentationParameters)
    at Microsoft.Xna.Framework.GraphicsDeviceManager.Microsoft.Xna.Framework.IGraphicsDeviceManager.CreateDevice()
    at Microsoft.Xna.Framework.GraphicsDeviceManager.get_GraphicsDevice()
    at Microsoft.Xna.Framework.Game.InitializeGraphicsService()
    at Microsoft.Xna.Framework.Game.DoInitialize()
    at Microsoft.Xna.Framework.Game.Run()
    at _8nVaf3yjm6bcC1Cp2wKyElgegaj._BHJf2c6GTW4qpzl71uAWe4jEeTC() in _5ofEB9D8PEAoelGzdy38UJCovGi:line 38

    Before this, the game would not start at all before I installed Visual C++ 2010 (x86). (No window or error message, just the 'MojoShader.Dll not found one'. Now that I have installed it, an empty window appears (Meaning I can see the exit/minimize/fullscreen stuff at the top right and the 'Amorous 0.4' at the top left, but I just see my desktop instead of the game.) and then after a few seconds I get the 'windows has encountered a problem' thing. I'm running it on Windows 7 BTW.
     
  2. Lennian

    Lennian Dark Lord of Team Amorous Team Amorous

    Messages:
    2,206
    Likes Received:
    928
    Can you delete all crashlogs, make it crash again and post the result of that? I would expect a different crash, so just to rule out mistakes.

    Other than that, please state your PC specs :)
     
  3. ThatOneGuy289

    ThatOneGuy289 New Member

    Messages:
    5
    Likes Received:
    0
    I deleted the logs, and tried to start the game again, but for some reason after it crashed, there were no logs. I tried refreshing the windows explorer thingy, and tried starting it multiple times, but it still just didn't make a log.

    Here's my system specs:
    CPU: Intel Atom N280 @ 1.66GHz
    RAM: 2.00GB Single-Channel DDR2 @ 265MHz (4-4-4-12)
    Graphics: (I'm just copy pasting what is on here.): Intel Mobile Intel 945 Express Chipset Family (Sony)
    Storage: 232GB TOSHIBA MK2555GSX ATA Device (SATA)
     
  4. Lennian

    Lennian Dark Lord of Team Amorous Team Amorous

    Messages:
    2,206
    Likes Received:
    928
    That would be a pretty nasty crash then - and I wouldn't be surprised if it's hardware related, those specs are... meh-ish. Try updating your drivers. Which windows are you on, etc.
     
  5. ThatOneGuy289

    ThatOneGuy289 New Member

    Messages:
    5
    Likes Received:
    0
    I'm running Windows 7 Home Premium 32-bit Service Pack 1.

    I tried updating my drivers (I used Driver Booster if that information is relevant.) and I still get the same thing. Another thing I noticed is that sometimes when I try to start the game and I don't immediately click the 'close the program' windows error thingy, the 'hollow' box will turn into a white background that fills the screen. But the windows error thing is still there and it crashes if I try to click the white. Just thought I might mention that,
     
  6. Lennian

    Lennian Dark Lord of Team Amorous Team Amorous

    Messages:
    2,206
    Likes Received:
    928
    The white box is good. Look for a crashlog in your gamefolder. What kind of videocard are you on?
     
  7. ThatOneGuy289

    ThatOneGuy289 New Member

    Messages:
    5
    Likes Received:
    0
    Still no crash log. And didn't I already mention the card I'm using when I posted my specs? I think it's that my laptop is using the CPU or something as the videocard. I think.
     
  8. Lennian

    Lennian Dark Lord of Team Amorous Team Amorous

    Messages:
    2,206
    Likes Received:
    928
    Yes you did, my bad. I'm inclined to call it below minimum specifications for now...
     
  9. ThatOneGuy289

    ThatOneGuy289 New Member

    Messages:
    5
    Likes Received:
    0
    Hmm. Well, thanks for trying.
     

Share This Page