Shoutbox (Disabled)

Support Error won't let me open the game after downloading

Discussion in 'Support' started by BigDaddy, Jun 4, 2017.

  1. BigDaddy

    BigDaddy New Member

    Messages:
    4
    Likes Received:
    0
    After downloading the game and attempting to play it, I'm given this error:

    Oh no, a crash!

    Microsoft.Xna,Framework.Graphics.NoSuitableGraphicsDeviceException: OpenGL 2.1 support is required!

    This may indicate you are do not have proper drivers installed for your GPU, the game uses the wrong GPU (eg. laptops) or your system does not meet minimum requirements.

    Do you wish to open a link with more information?

    I'm currently using a desktop with windows 10, 3.00GHz processor, and 8GB RAM, so I'm pretty sure the problem is with the drivers. What do I do about this? I don't really know what a driver is, nor do I know how to install proper ones for my GPU.
     
  2. Lennian

    Lennian Dark Lord of Team Amorous Team Amorous

    Messages:
    2,207
    Likes Received:
    935
    Easy to find out. Browse to where the launcher is located, then go to games/amorous/windows and there should a few crash-logs in there. Open it up, and on the top it should say something similar to:
    Post that here, and I'll point you into the right direction.
     
  3. BigDaddy

    BigDaddy New Member

    Messages:
    4
    Likes Received:
    0
    I found two crash logs. Here they are:

    [0000.47] Error: Unhandled exception: Microsoft.Xna.Framework.Graphics.NoSuitableGraphicsDeviceException: OpenGL 2.1 support is required!
    at Microsoft.Xna.Framework.Graphics.OpenGLDevice.LoadGLEntryPoints() in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\FNAPlatform\OpenGLDevice_GL.cs:line 1069
    at Microsoft.Xna.Framework.Graphics.OpenGLDevice..ctor(PresentationParameters presentationParameters, GraphicsAdapter adapter) in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\FNAPlatform\OpenGLDevice.cs:line 585
    at Microsoft.Xna.Framework.SDL2_FNAPlatform.CreateGLDevice(PresentationParameters presentationParameters, GraphicsAdapter adapter) in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\FNAPlatform\SDL2_FNAPlatform.cs:line 799
    at Microsoft.Xna.Framework.Graphics.GraphicsDevice..ctor(GraphicsAdapter adapter, GraphicsProfile graphicsProfile, PresentationParameters presentationParameters) in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\Graphics\GraphicsDevice.cs:line 400
    at Microsoft.Xna.Framework.GraphicsDeviceManager.Microsoft.Xna.Framework.IGraphicsDeviceManager.CreateDevice() in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\GraphicsDeviceManager.cs:line 404
    at Microsoft.Xna.Framework.GraphicsDeviceManager.get_GraphicsDevice() in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\GraphicsDeviceManager.cs:line 40
    at Microsoft.Xna.Framework.Game.InitializeGraphicsService() in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\Game.cs:line 905
    at Microsoft.Xna.Framework.Game.DoInitialize() in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\Game.cs:line 821
    at Microsoft.Xna.Framework.Game.Run() in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\Game.cs:line 414
    at _ScxVr1b3znMlkcqhwRUJUCR1hmC._yiuG5Xa0jOI7w13AEOPEXAQh2Nt() in _4rIgSs9Z83pUiVrfW41sBd8gNAQ:line 48



    [0000.48] Error: Unhandled exception: Microsoft.Xna.Framework.Graphics.NoSuitableGraphicsDeviceException: OpenGL 2.1 support is required!
    at Microsoft.Xna.Framework.Graphics.OpenGLDevice.LoadGLEntryPoints() in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\FNAPlatform\OpenGLDevice_GL.cs:line 1069
    at Microsoft.Xna.Framework.Graphics.OpenGLDevice..ctor(PresentationParameters presentationParameters, GraphicsAdapter adapter) in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\FNAPlatform\OpenGLDevice.cs:line 585
    at Microsoft.Xna.Framework.SDL2_FNAPlatform.CreateGLDevice(PresentationParameters presentationParameters, GraphicsAdapter adapter) in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\FNAPlatform\SDL2_FNAPlatform.cs:line 799
    at Microsoft.Xna.Framework.Graphics.GraphicsDevice..ctor(GraphicsAdapter adapter, GraphicsProfile graphicsProfile, PresentationParameters presentationParameters) in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\Graphics\GraphicsDevice.cs:line 400
    at Microsoft.Xna.Framework.GraphicsDeviceManager.Microsoft.Xna.Framework.IGraphicsDeviceManager.CreateDevice() in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\GraphicsDeviceManager.cs:line 404
    at Microsoft.Xna.Framework.GraphicsDeviceManager.get_GraphicsDevice() in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\GraphicsDeviceManager.cs:line 40
    at Microsoft.Xna.Framework.Game.InitializeGraphicsService() in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\Game.cs:line 905
    at Microsoft.Xna.Framework.Game.DoInitialize() in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\Game.cs:line 821
    at Microsoft.Xna.Framework.Game.Run() in E:\Projecten\Jasonafex\Git\Amorous\amorous\Lib\FNA\src\Game.cs:line 414
    at _ScxVr1b3znMlkcqhwRUJUCR1hmC._yiuG5Xa0jOI7w13AEOPEXAQh2Nt() in _4rIgSs9Z83pUiVrfW41sBd8gNAQ:line 48
     
  4. Lennian

    Lennian Dark Lord of Team Amorous Team Amorous

    Messages:
    2,207
    Likes Received:
    935
    You left out the important bit, I needed the first few lines which state your graphics card, not the actual crash :p The crashlog server has already determined what's the cause.

    EDIT: Nvm... if the game crashed too early, it doesn't get the chance to print that information.

    Open up DXDiag (it's a tool that comes with DirectX) and switch to the Monitor-tab. What kind of device does it report? Name/Brand/Chip.
     
  5. BigDaddy

    BigDaddy New Member

    Messages:
    4
    Likes Received:
    0
    When I open the display tab, it says the name of the device is an Intel Q35 Express Chipset Family
     
  6. Lennian

    Lennian Dark Lord of Team Amorous Team Amorous

    Messages:
    2,207
    Likes Received:
    935
    Afraid you are out of the luck, the Q35 has OpenGL support up till 1.5 - no driver is going to fix that - you need 2.1 at least to run any modern game these days. With such a machine I would recommend investing into a modern GPU. Even a last-gen version of 30 bucks is already better than the Intel you have right now.

    Or ask your local tech geek if your PC doesn't happen to have a better GPU (I would almost imagine with those specs). It's quite likely it's simply miss configured.
     
  7. BigDaddy

    BigDaddy New Member

    Messages:
    4
    Likes Received:
    0
    Alright, that's what I was thinking, I'll need to update my computer's hardware. Thanks.
     

Share This Page